quando digito "sudo apt-get -f install" mi dice comando non trovato

chiesto 10 Feb '22, 14:59

redphilip64's gravatar image

redphilip64
20123


12avanti »

Ciao, prova ad invertire le ultime due parole. sudo apt-get install -f

coll. permanente

ha risposto 10 Feb '22, 15:21

jusuf-1969's gravatar image

jusuf-1969
19112

CIao grazie per l'aiuto , ma ho un casino nel pc, non mi fà aggiornare più i pacchetti, errore brokentCount 0

coll. permanente

ha risposto 10 Feb '22, 15:43

redphilip64's gravatar image

redphilip64
20123

ma aprendo un terminale se esegui:

sudo apt update

che dice?

p.s. https://wiki.ubuntu-it.org/AmministrazioneSistema/Terminale?action=show&redirect=AmministrazioneSistema%2FRigaDiComando#Avviare_il_terminale

p.s. hai aggiunto dei repository o ppa?

(10 Feb '22, 20:26) sacarde sacarde's gravatar image

redphilip@redphilip-Lenovo-V110-15AST:~$ sudo apt update [sudo] password di redphilip: Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu impish InRelease [270 kB] Trovato:2 http://archive.canonical.com/ubuntu impish InRelease
Trovato:3 https://brave-browser-apt-release.s3.brave.com stable InRelease
Scaricamento di:4 https://repo.protonvpn.com/debian unstable InRelease [2.521 B] Scaricamento di:5 http://security.ubuntu.com/ubuntu impish-security InRelease [110 kB] Trovato:6 http://it.archive.ubuntu.com/ubuntu impish-updates InRelease
Trovato:7 http://it.archive.ubuntu.com/ubuntu focal-updates InRelease
Trovato:8 https://repo.protonvpn.com/debian stable InRelease
Trovato:9 http://it.archive.ubuntu.com/ubuntu focal InRelease
Trovato:10 http://it.archive.ubuntu.com/ubuntu impish-backports InRelease Scaricamento di:11 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB] Recuperati 497 kB in 2s (256 kB/s)
Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze... Fatto Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati. W: Acquisizione del file "main/source/Sources" saltata in quanto il repository "https://repo.protonvpn.com/debian unstable InRelease" non sembra fornire tale file (voce in sources.list errata?) redphilip@redphilip-Lenovo-V110-15AST:~$

coll. permanente

ha risposto 11 Feb '22, 10:25

redphilip64's gravatar image

redphilip64
20123

hai aggiunto tu il repo: "https://repo.protonvpn.com/debian unstable InRelease"

hai seguito una guida?

  • puoi gestire i repo anche da:

software-properties-gtk

(11 Feb '22, 10:54) sacarde sacarde's gravatar image

si l'ho aggiunto io forse per errore, il fatto è che non riesco più ad aggiornare nulla perchè mi da errore sottopacchetto linux 5.13.0-25 generic......vorrei reinstallare Ubuntu 21.10

coll. permanente

ha risposto 11 Feb '22, 11:10

redphilip64's gravatar image

redphilip64
20123

È utile eseguire "apt --fix-broken install" per correggere ciò. I seguenti pacchetti hanno dipendenze non soddisfatte: linux-modules-5.13.0-28-generic : Dipende: linux-image-5.13.0-28-generic ma non sta per essere installato oppure linux-image-unsigned-5.13.0-28-generic ma non sta per essere installato E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).

coll. permanente

ha risposto 11 Feb '22, 11:13

redphilip64's gravatar image

redphilip64
20123

"apt --fix-broken install" comando non trovato

coll. permanente

ha risposto 11 Feb '22, 11:15

redphilip64's gravatar image

redphilip64
20123

ma dal comando: software-properties-gtk

riesci a togliere il repo aggiunto? (togliendo la spunta)

p.s. puoi anche reinstallare tutto dalla live (dvd o usb)

p.s. oppure togli la riga aggiunta nel file: /etc/apt/sources.list https://repo.protonvpn.com/... ecc

(11 Feb '22, 14:24) sacarde sacarde's gravatar image

Allora, ho eliminato il repo protonvpn, ma il problema rimane uguale , non mi fà aggiornare nulla, pensa che avevo installato Geary come programma di posta e adesso non riesco a dissintallarlo perchè mi dà errore nel pacchetto: mi dice Impossibile rimuovere Geary Error while installing package: il sottoprocesso installato pacchetto linux-image-5.13.0-28 generic script post-removal ha restituito lo stato di errore 1

coll. permanente

ha risposto 11 Feb '22, 14:48

redphilip64's gravatar image

redphilip64
20123

e il comando:

sudo apt-get -f install

sempre errore?

oppure: sudo apt update

(11 Feb '22, 15:00) sacarde sacarde's gravatar image

redphilip@redphilip-Lenovo-V110-15AST:~$ sudo apt-get -f install [sudo] password di redphilip: Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze... Fatto Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti: efibootmgr grub-efi-amd64-bin grub-efi-amd64-signed libsysmetrics1 Usare "sudo apt autoremove" per rimuoverli. I seguenti pacchetti aggiuntivi saranno inoltre installati: linux-image-unsigned-5.13.0-28-generic Pacchetti suggeriti: linux-tools linux-headers-5.13.0-28-generic linux-modules-extra-5.13.0-28-generic I seguenti pacchetti saranno RIMOSSI: linux-image-5.13.0-28-generic I seguenti pacchetti NUOVI saranno installati: linux-image-unsigned-5.13.0-28-generic 0 aggiornati, 1 installati, 1 da rimuovere e 0 non aggiornati. 9 non completamente installati o rimossi. È necessario scaricare 0 B/10,2 MB di archivi. Dopo quest'operazione, verranno occupati 282 kB di spazio su disco. Continuare? [S/n] dpkg: linux-image-5.13.0-28-generic: problemi con le dipendenze, ma viene rimosso comunque: linux-modules-5.13.0-28-generic dipende da linux-image-5.13.0-28-generic | linux-image-unsigned-5.13.0-28-generic; tuttavia: Il pacchetto linux-image-5.13.0-28-generic sta per essere rimosso. Il pacchetto linux-image-unsigned-5.13.0-28-generic non è installato.

(Lettura del database... 238846 file e directory attualmente installati.) Rimozione di linux-image-5.13.0-28-generic (5.13.0-28.31)... /etc/kernel/postrm.d/initramfs-tools: update-initramfs: Deleting /boot/initrd.img-5.13.0-28-generic /etc/kernel/postrm.d/zz-update-grub: Lettura file "/etc/default/grub" /usr/sbin/grub-mkconfig: 1: /etc/default/grub: Roll#: not found run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127 dpkg: errore nell'elaborare il pacchetto linux-image-5.13.0-28-generic (--remove): il sottoprocesso installato pacchetto linux-image-5.13.0-28-generic script post-removal ha restituito lo stato di errore 1 dpkg: troppi errori, chiusura in corso Si sono verificati degli errori nell'elaborazione: linux-image-5.13.0-28-generic L'operazione è stata bloccata perché si sono verificati troppi errori. E: Sub-process /usr/bin/dpkg returned an error code (1)

coll. permanente

ha risposto 11 Feb '22, 15:32

redphilip64's gravatar image

redphilip64
20123

redphilip@redphilip-Lenovo-V110-15AST:~$ sudo apt update Scaricamento di:1 http://it.archive.ubuntu.com/ubuntu impish InRelease [270 kB] Trovato:2 http://archive.canonical.com/ubuntu impish InRelease
Scaricamento di:3 http://security.ubuntu.com/ubuntu impish-security InRelease [110 kB] Trovato:4 https://brave-browser-apt-release.s3.brave.com stable InRelease
Trovato:5 https://repo.protonvpn.com/debian stable InRelease
Trovato:6 http://it.archive.ubuntu.com/ubuntu impish-updates InRelease
Scaricamento di:7 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB] Trovato:8 http://it.archive.ubuntu.com/ubuntu focal-updates InRelease Trovato:9 http://it.archive.ubuntu.com/ubuntu focal InRelease Trovato:10 http://it.archive.ubuntu.com/ubuntu impish-backports InRelease Scaricamento di:11 http://security.ubuntu.com/ubuntu impish-security/main amd64 DEP-11 Metadata [11,7 kB] Scaricamento di:12 http://security.ubuntu.com/ubuntu impish-security/universe amd64 DEP-11 Metadata [2.608 B] Recuperati 508 kB in 2s (280 kB/s)
Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze... Fatto Lettura informazioni sullo stato... Fatto
Tutti i pacchetti sono aggiornati.

coll. permanente

ha risposto 11 Feb '22, 15:33

redphilip64's gravatar image

redphilip64
20123

ma il simbolo rosso tipo divieto in altro a destra cè sempre..... aiutoooo!!

coll. permanente

ha risposto 11 Feb '22, 15:34

redphilip64's gravatar image

redphilip64
20123

e se provi a fare l'aggiornamento?

sudo apt update

sudo apt upgrade

(11 Feb '22, 17:41) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×23

domanda posta: 10 Feb '22, 14:59

domanda visualizzata: 1,229 volte

ultimo aggiornamento: 24 Jan, 08:22

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.