Buongiorno, Ho installato Ubuntu 20.04.3 in parallelo a win 11Home su un laptop Samsung 750XDA. Ubuntu non vede la scheda WIFI ed il PC non ha connessione via cavo. Suggerimeti?

chiesto 20 Feb '22, 11:57

sergio-roveri's gravatar image

sergio-roveri
2012

quale scheda hai?

esegui: "lspci" se e' PCI

esegui: "lsusb" se e' usb

(20 Feb '22, 20:33) sacarde sacarde's gravatar image

Scusa la mia incompetenza, nella schermata da comando lspci gli unici dati ottenuti che mi sembrano riferirsi alla scheda sono: System peripheral Intel corporation device 9a11 (rev 01) Oppure : communication controller intel corporation device a0e0 (rev 20) Se non sono questi, potresti dirmi a Cosa dovrebbe assomigliare la descrizione della scheda?

Dal lato Windows vedo Intel(R) Wi-Fi 6 AX201 160MHz

(20 Feb '22, 22:14) sergio-roveri sergio-roveri's gravatar image

se esegui: lspci -nnpk

cosa vedi a riguardo della "System peripheral Intel corporation device 9a11"

i numeri tra "[..:..]"

(21 Feb '22, 08:07) sacarde sacarde's gravatar image

dovrebbe usare il driver/modulo iwlwifi

cosa vedi da: iwconfig

o da: dmesg | grep wlan

(21 Feb '22, 09:55) sacarde sacarde's gravatar image

da: lspci -nnpk vedo 02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 61) da: iwconfig vedo lo no wireless extensions.

(21 Feb '22, 10:04) sergio-roveri sergio-roveri's gravatar image

da: dmesg | grep wlan vedo
[ 4.023299] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0

(21 Feb '22, 10:07) sergio-roveri sergio-roveri's gravatar image

se ho ben capito hai identificato il driver, a questo punto dove lo trovo e come lo carico?

(21 Feb '22, 10:08) sergio-roveri sergio-roveri's gravatar image

veramente crea il device wlp2s0

che vedi da: dmesg | grep wlp2s0

e da: dmesg | grep iwl

p.s. il dispositivo e' questo: https://linux-hardware.org/?id=pci:8086-095a-8086-5000

(21 Feb '22, 10:24) sacarde sacarde's gravatar image

aggiungo che la mia è una situazione Kafkiana perchè il mio pc non ha connessione a filo, e quindi senza driver non posso connetermi alla rete.

(21 Feb '22, 10:26) sergio-roveri sergio-roveri's gravatar image

che vedi da: dmesg | grep wlp2s0

e da: dmesg | grep iwl

(21 Feb '22, 10:40) sacarde sacarde's gravatar image

dmesg | grep iwl (5.081049) iwlwifi 0000:00:14.3: enabling device (0000 -> 0002) (5.085607) iwlwifi: no config found for PCI dev a0f0/6074, rev=0x354, rfid=0x10a100 (5.088631) iwlwifi: probe of 0000:00:14.3 failed with error -22

(21 Feb '22, 11:08) sergio-roveri sergio-roveri's gravatar image
  • che vedi da:

systool -vm iwlwifi

(la parte dei parametri)

  • che vedi da: rfkill list
(21 Feb '22, 11:21) sacarde sacarde's gravatar image

Il primo comando non è riconosciuto né installabile. Il secondo mi dà: 0: hci0: bluetoot
Software blocked: no
Hard blocked: no

(21 Feb '22, 12:18) sergio-roveri sergio-roveri's gravatar image

questo?

grep -H '' /sys/module/iwlwifi/parameters/*

(21 Feb '22, 13:39) sacarde sacarde's gravatar image

mi dà operazione non valida.
proposta: e se cancellassi ubuntu per installare 21.10 ?
potresti suggerire come fare a cancellare 20.04 (formattare la partizione?) ed installare 21.10. Il GRUB/bios mi impedisce di installare da USB che non viene vista

(21 Feb '22, 15:33) sergio-roveri sergio-roveri's gravatar image
  • dopo la "H" non e' un doppio apice, ma 2 apici singoli '

  • una prova live della 21.10 puoi sempre farla, anche prima di installarla, per vedere se funziona senza fare modifiche

  • se vuoi cancellare la 20.04 basta che tu selezioni la partizione "/" come la partizione dove installare il sistema

  • e' un vecchio bios che non fa avviare la usb?

(21 Feb '22, 17:02) sacarde sacarde's gravatar image

ecco i dati del comando riscritto con apici: te lo mando in due parti per ragioni di spazio in commenti sergio@sergio-750XDA:~$ grep -H '' /sys/module/iwlwifi/parameters/* /sys/module/iwlwifi/parameters/11n_disable:0 /sys/module/iwlwifi/parameters/amsdu_size:0 /sys/module/iwlwifi/parameters/bt_coex_active:Y /sys/module/iwlwifi/parameters/disable_11ac:N

(22 Feb '22, 10:13) sergio-roveri sergio-roveri's gravatar image

/sys/module/iwlwifi/parameters/disable_11ax:N /sys/module/iwlwifi/parameters/enable_ini:Y /sys/module/iwlwifi/parameters/fw_restart:Y /sys/module/iwlwifi/parameters/led_mode:0 /sys/module/iwlwifi/parameters/nvm_file:(null) /sys/module/iwlwifi/parameters/power_level:0 /sys/module/iwlwifi/parameters/power_save:N /sys/module/iwlwifi/parameters/remove_when_gone:N /sys/module/iwlwifi/parameters/swcrypto:0 /sys/module/iwlwifi/parameters/uapsd_disable:3

(22 Feb '22, 10:13) sergio-roveri sergio-roveri's gravatar image

rispondo all'ultima domanda: No è un pc nuovo, ho solo dei problemi con Bios e grub che si è messo a bloccare il riavvio da usb

(22 Feb '22, 10:14) sergio-roveri sergio-roveri's gravatar image

ho provato in live 21.10 anche questa non vede la wifi

(22 Feb '22, 10:54) sergio-roveri sergio-roveri's gravatar image
  • hai il secureboot attivo?

  • e' una scheda anche bluetooth? si puo provare a disabilitare la coesistenza e si puo disattivare la connessione "11n"

con i comandi:

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=1 bt_coex_active=N

  • cosa vedi dal comando: "ip a"

p.s. dalla applet networkmanager vedi la scheda: wlp2s0

(22 Feb '22, 11:11) sacarde sacarde's gravatar image

un aggiornamento bios lo aveva riattivato, dopo averlo nuovamente disattivato sono riuscito a vedere 21.10 che per, almeno in live, non vede il wifi.

(22 Feb '22, 16:07) sergio-roveri sergio-roveri's gravatar image

sergio@sergio-750XDA:~$ ''ip a'' 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever

(22 Feb '22, 16:08) sergio-roveri sergio-roveri's gravatar image

dalle Impostazioni vedo solo la funzione Rete che non mostra niente. Se ti riferisci ad un'altra applet non posso caricarla perchè con c'è la rete.

(22 Feb '22, 16:12) sergio-roveri sergio-roveri's gravatar image

provato questo: sergio@sergio-750XDA:~$ lspci -vvnn | grep -A 9 Network 00:14.3 Network controller [0280]: Intel Corporation Device [8086:a0f0] (rev 20) DeviceName: Onboard - Ethernet Subsystem: Intel Corporation Device [8086:6074] Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx- Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <tabort- <mabort-="">SERR- <perr- intx-="" interrupt:="" pin="" a="" routed="" to="" irq="" 16="" region="" 0:="" memory="" at="" 6001144000="" (64-bit,="" non-prefetchable)="" [size="16K]" capabilities:="" <access="" denied=""> Kernel modules: iwlwifi

(22 Feb '22, 17:38) sergio-roveri sergio-roveri's gravatar image

posso usare ndiswrapper ? e come si fa? :-)

(22 Feb '22, 17:53) sergio-roveri sergio-roveri's gravatar image
  • dal BIOS hai il secureboot attivo?

  • cambia qualcosa se esegui i comandi:

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=1 bt_coex_active=N

  • la scheda ethernet c'e' ma non puoi usarla, e' vero?
(22 Feb '22, 18:02) sacarde sacarde's gravatar image

ho ridisattivato secureboot e sono riuscito a vedere 21.10 e la scheda wifi non si vede nemmeno con quello.
Ho eseguito i due comandi sudo... ma non vedo niente di nuovo. La scheda wifi c'è perchè dal lato windows11 funziona, quindi in Windows c'è anche il driver, si riesce ad usarlo con ndiswrapper?

(23 Feb '22, 09:41) sergio-roveri sergio-roveri's gravatar image
  • dopo aver eseguito i 2 comandi "sudo modprobe ..."

cosa vedi nelle ultime 10 righe dal comando: "dmesg" ?

p.s. da qui sembra compatibile e funzionante

https://linux-hardware.org/?id=pci:8086-a0f0-8086-0070

(23 Feb '22, 09:56) sacarde sacarde's gravatar image

[ 4315.743140] ACPI Error: Aborting method _SB.PEPD._DSM due to previous error (AE_NOT_FOUND) (20201113/psparse-529) [ 4315.744000] ACPI: EC: interrupt unblocked [ 4315.811352] nvme nvme0: 8/0/0 default/read/poll queues [ 4318.301961] ACPI: EC: 0 stale EC events cleared [ 4318.492108] OOM killer enabled. [ 4318.492108] Restarting tasks ... [ 4318.492968] mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915]) [ 4318.493835] done. [ 4318.602164] PM: suspend exit sergio@sergio-750XDA:~/Scrivania$

(23 Feb '22, 10:51) sergio-roveri sergio-roveri's gravatar image

mah!

  • OOM killer e' quando va in "out of memory", quanta ram hai?

  • da BIOS/uefi hai il secureboot attivo?

  • che vedi da: dmesg | grep wlp2s0

(23 Feb '22, 11:52) sacarde sacarde's gravatar image

Ram 16GB
secureboot off
da dmesg | grep wlp2s0 se il comando è un filtro messaggi, eseguendolo non compare nulla. Il comando dmesg eseguito successivamente mi da una lunga lista. Ti interessa?

(23 Feb '22, 12:40) sergio-roveri sergio-roveri's gravatar image
  • quindi "dmesg" non ti da piu' la riga:

iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0

  • ricapitolando dalle impostazioni del bios: fast boot = Disable. secure boot = Disable. Boot mode select =UEFI

  • proverei a passare al kernel (per prova) il parametro: acpi=off

istruzioni passare parametri al kernel: temporaneamente https://wiki.ubuntu.com/Kernel/KernelBootParameters#Temporarily_Add_a_Kernel_Boot_Parameter_for_Testing

(23 Feb '22, 14:16) sacarde sacarde's gravatar image

seguendo le istruzioni, dopo splash ho digitato : spazio seguito da acpi=off lasciando uno spazio prima di $vt_handoff poi ho premuto control+x per il booting e il sistema si è piantato, dopo 5 minuti ho resettato. A quanto pare non ha funzionato a meno che non fosse necessario attendere un tempo molto maggiore. A questo punto ho ordinato un convertitore Usb rj45 ed aspetto speranzoso la prossima edizione di Ubuntu.

(25 Feb '22, 12:11) sergio-roveri sergio-roveri's gravatar image
  • quindi "dmesg" non ti da piu' la riga:

iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0

  • mmm, non ho mai sperimentato l'ethernet su usb, sono curioso di vedere come va

  • in alternativa prendere una usb wireless copatibile

http://linux-wless.passys.nl/query_alles.php?

(25 Feb '22, 18:31) sacarde sacarde's gravatar image

Ho comprato un convertitore USB RJ45 modello Techole UH411, funziona senza problemi, il miracolo è che adesso il pc riconosce anche la scheda di rete! Giuro che non sono ricorso ad un esorcista! Ringrazio il carissimo Sacarde per il tempo che mi ha dedicato.!

coll. permanente

ha risposto 28 Feb '22, 12:38

sergio-roveri's gravatar image

sergio-roveri
2012

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×153

domanda posta: 20 Feb '22, 11:57

domanda visualizzata: 664 volte

ultimo aggiornamento: 28 Feb '22, 12:38

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.