Buonasera a tutti!

Sabato ho installato Ubuntu Budgie sul mio iMac 21 pollici di fine 2013. Un computer che andava bene fino a quando non ci hanno messo le mani per mettere un hard disk allo stato solido. Purtroppo, deve essere successo qualcosa con l'installazione e, da quello che mi hanno riferito, il sensore di temperatura dell'hard disk non è stato collegato o si è scollato (così si dice).

Era stato formattato e si era installato macos Catalina (l'ultima versione supportata). Purtroppo, la ventola girava velocemente e c'era un processo che "intasava" il kernel e mandava l'utilizzo cpu a livelli folli (80%). mi hanno detto che dipendeva dal fatto che il sistema mac credeva che l'hard disk fosse sul punto di collassare per le alte temperature... poi non so.

Avevo installato pure un programmino che rallenta le ventole, ma niente da fare. L'uso processore era altissimo.

Morale della favola: ho installato Budgie, ma la ventola gira ancora velocissimamente... e oggi ho visto che il processore (uno dei 4) aveva degli strani picchi di utilizzo non giustificati da processi in corso.

Chiedo gentilmente aiuto :)

grazie

Giovanni

chiesto 02 May '22, 20:46

giovannibrunoro's gravatar image

giovannibrunoro
1011

  • dal comando "top" vedi quale processo usa piu' CPU

  • sembra un problema hardware

  • anche dal "live" fa lo stesso?

(03 May '22, 09:08) sacarde sacarde's gravatar image

Ho aperto il system monitor... cpu1 va all'80% costante... le altre meno ... ma, se vado alla gestione dei processi, vedo che gnome system monitor è, con appena il 2,5%, il processo più attivo.. in questo momento ho tutto fermo, nessun programma attivo. Credo sia un problema hardware... non so poi cosa intendi con "live"...

(03 May '22, 11:52) giovannibrunoro giovannibrunoro's gravatar image
  • da top:

premi "M" per ordinare per uso memoria

"P" per ordinare per uso cpu

  • facendo partire il dvd o la chiavetta di installazione
(03 May '22, 14:41) sacarde sacarde's gravatar image

il processo che consuma di più è "root" con una media del 3% ... in questo momento la cpu consuma pochissimo... ma c'è la ventola a palla. per quanto riguarda la ram, direi che il processo è sempre "root", con pochissime percentuali...

(03 May '22, 15:02) giovannibrunoro giovannibrunoro's gravatar image

dentro top il comando COMMAND e' "root" ??

ma hai premuto "P" per la cpu o "M" per la memoria?

(03 May '22, 15:13) sacarde sacarde's gravatar image

sì certamente... l'uso della cpu era molto sceso ...devo provare a capire se è una cosa che fa quando fa l'avvio di sistema e poi si calma ... anche se la ventola va sempre velocemente e vorrei un modo per rallentarla...

(03 May '22, 15:26) giovannibrunoro giovannibrunoro's gravatar image

"dentro top il comando COMMAND e' "root" ??"

qui non riesco a capire...

(03 May '22, 15:38) giovannibrunoro giovannibrunoro's gravatar image

il processo non e "root", ma il proprietario, cosa vedi nella colonna "COMMAND"

https://i.imgur.com/fcUUlD1.png

(03 May '22, 17:29) sacarde sacarde's gravatar image

ho visto un xorg con il 32% poi gnome e budgie ... cosa caspita è xorg?

(03 May '22, 20:50) giovannibrunoro giovannibrunoro's gravatar image

xorg e' il server grafico..

che scheda video usi? quali driver grafici usi?

(03 May '22, 23:47) sacarde sacarde's gravatar image

c'è un modo sicuro per vederlo?

(04 May '22, 00:32) giovannibrunoro giovannibrunoro's gravatar image

c'è un modo per vederlo?

coll. permanente

ha risposto 04 May '22, 00:32

giovannibrunoro's gravatar image

giovannibrunoro
1011

prova a eseguire:

lspci -nnk | grep -i vga -a3

p.s. qui per gestire i driver

https://wiki.ubuntu-it.org/Hardware/AbilitareDriverProprietari

(04 May '22, 08:09) sacarde sacarde's gravatar image

00:00.0 Host bridge [0600]: Intel Corporation Crystal Well DRAM Controller [8086:0d00] (rev 08) Subsystem: Apple Inc. Crystal Well DRAM Controller [106b:0122] 00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:0d22] (rev 08) Subsystem: Apple Inc. Device [106b:0122] Kernel driver in use: i915 Kernel modules: i915

ps: sono riuscito a vedere quale processo impegna tantisismo la cpu all'avvio: si chiama kworker+

(04 May '22, 10:36) giovannibrunoro giovannibrunoro's gravatar image
  • ok, il modulo e' quello intel i915

non vedi altra scelta vero? da https://wiki.ubuntu-it.org/Hardware/AbilitareDriverProprietari

  • cosa vedi dal comando: grep . -r /sys/firmware/acpi/interrupts/
(04 May '22, 13:45) sacarde sacarde's gravatar image

Vedo solo una robetta per quanto riguarda la scheda wireless... ma niente sulla scheda grafica ... ecco qui sotto l'esito della stringa che mi hai segnalato ...

/sys/firmware/acpi/interrupts/gpe2F: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe23: 0 disabled unmasked /sys/firmware/acpi/interrupts/gpe1F: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe13: 0 EN enabled unmasked /sys/firmware/acpi/interrupts/gpe0F: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe03: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3D: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe31: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe2D: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe21: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe1D: 0 invalid unmasked /sys/firmware/acpi/interrupts/ff_pwr_btn: 0 EN enabled unmasked /sys/firmware/acpi/interrupts/gpe11: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe0D: 0 disabled unmasked /sys/firmware/acpi/interrupts/gpe01: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3B: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe2B: 0 invalid unmasked /sys/firmware/acpi/interrupts/ff_rt_clk: 0 disabled unmasked /sys/firmware/acpi/interrupts/ff_pmtimer: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe1B: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe38: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe0B: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe28: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe18: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe08: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe36: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe26: 0 invalid unmasked /sys/firmware/acpi/interrupts/error: 0 /sys/firmware/acpi/interrupts/gpe16: 0 invalid unmasked /sys/firmware/acpi/interrupts/sci: 2171374 /sys/firmware/acpi/interrupts/gpe06: 2170215 STS enabled unmasked /sys/firmware/acpi/interrupts/gpe34: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe24: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe14: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe04: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3E: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe32: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe2E: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe22: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe1E: 0 disabled unmasked /sys/firmware/acpi/interrupts/gpe12: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe0E: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe02: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3C: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe30: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe2C: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe20: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe1C: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe10: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe39: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe0C: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe00: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3A: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe_all: 2172138 /sys/firmware/acpi/interrupts/gpe29: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe2A: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe19: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe1A: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe09: 0 EN enabled unmasked /sys/firmware/acpi/interrupts/gpe37: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe0A: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe27: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe17: 1870 EN enabled unmasked /sys/firmware/acpi/interrupts/ff_gbl_lock: 0 EN enabled unmasked /sys/firmware/acpi/interrupts/gpe07: 0 enabled unmasked /sys/firmware/acpi/interrupts/sci_not: 69960 /sys/firmware/acpi/interrupts/gpe35: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe25: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe15: 0 EN enabled unmasked /sys/firmware/acpi/interrupts/gpe05: 0 invalid unmasked /sys/firmware/acpi/interrupts/gpe3F: 0 STS invalid unmasked /sys/firmware/acpi/interrupts/gpe33: 0 invalid unmasked /sys/firmware/acpi/interrupts/ff_slp_btn: 0 invalid unmasked

coll. permanente

ha risposto 04 May '22, 14:05

giovannibrunoro's gravatar image

giovannibrunoro
1011

scusa, cosi non ci capisco, riesci a pastarlo qui:

https://paste.debian.net/

(04 May '22, 14:10) sacarde sacarde's gravatar image

Ecco così dovrebbe andare

https://paste.debian.net/1239906/

coll. permanente

ha risposto 04 May '22, 14:22

giovannibrunoro's gravatar image

giovannibrunoro
1011

ok, quindi seguendo qui https://www.blograffo.net/ubuntu-1-core-cpu-sempre-al-90-100/

il valore fuori controllo sarebbe in /sys/firmware/acpi/interrupts/gpe06

per cui inserire in /etc/rc.local

echo "disable" > /sys/firmware/acpi/interrupts/gpe06

e riavviare il servizio

sudo systemctl restart rc.local.service

(04 May '22, 14:29) sacarde sacarde's gravatar image

Scusa, non ho ben capito i passaggi ... sono nuovo a questo genere di sistemi. che dovrei fare?

(04 May '22, 14:31) giovannibrunoro giovannibrunoro's gravatar image

allora, per provare puoi eseguire dalla consolle:

sudo echo "disable" > /sys/firmware/acpi/interrupts/gpe06

e vedere se c'e' qualche cambiamento da "top"

(04 May '22, 14:35) sacarde sacarde's gravatar image

ci sto provando, ma mi dice "pemission denied"

(04 May '22, 14:51) giovannibrunoro giovannibrunoro's gravatar image

anche anteponendo "sudo" ?

oppure con:

sudo echo disable > /sys/firmware/acpi/interrupts/gpe06

(senza gli apici)

p.s. oppure prova prima del comando a eseguire: sudo -i e poi dai il comando

(04 May '22, 20:26) sacarde sacarde's gravatar image

Niente da fare

giovanni@giovanni-iMac:~$ sudo -i root@giovanni-iMac:~# sudo echo "disable" > /sys/firmware/acpi/interrupts/gpe06 echo: write error: Invalid argument root@giovanni-iMac:~# sudo echo disable > /sys/firmware/acpi/interrupts/gpe06 echo: write error: Invalid argument root@giovanni-iMac:~#

(04 May '22, 23:57) giovannibrunoro giovannibrunoro's gravatar image

prova a rieseguire (dopo sudo -i)

sudo echo enable > /sys/firmware/acpi/interrupts/gpe06

e poi

sudo echo disable > /sys/firmware/acpi/interrupts/gpe06

(05 May '22, 08:17) sacarde sacarde's gravatar image

Esce questo: echo: write error: Invalid argument

(05 May '22, 09:44) giovannibrunoro giovannibrunoro's gravatar image

se da errore con "disable" forse e' gia' disabilitato, controlla rieseguendo il comando:

grep . -r /sys/firmware/acpi/interrupts/ | grep gpe06

(05 May '22, 13:39) sacarde sacarde's gravatar image

giovanni@giovanni-iMac:~$ sudo -i [sudo] password for giovanni: root@giovanni-iMac:~# grep . -r /sys/firmware/acpi/interrupts/ | grep gpe06 /sys/firmware/acpi/interrupts/gpe06: 1150768 EN enabled unmasked

(05 May '22, 14:09) giovannibrunoro giovannibrunoro's gravatar image

strano.... a me lo fa fare (dopo che ho visto "enabled")

sudo echo disable > /sys/firmware/acpi/interrupts/gpe06

e me lo disabilita

(05 May '22, 14:46) sacarde sacarde's gravatar image

tra l'altro ho riavviato e visto all'avvio dei messaggi di errore che prima non notavo ... non vorrei dover riformattare tutto ..

(05 May '22, 14:50) giovannibrunoro giovannibrunoro's gravatar image
  • il comando agisce soltanto all'interno della sessione

e poi se ti ha sempre dato errore non hai mai "modificato" nulla

  • quali messaggi di errore?
(05 May '22, 15:14) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×120
×29

domanda posta: 02 May '22, 20:46

domanda visualizzata: 420 volte

ultimo aggiornamento: 05 May '22, 15:14

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.