Salve, sono principiante, ho installato Ubuntu 22.04. Premetto che l'installazione automatica non mi è stata possibile perchè non mi riconosceva Windows ed allora ho continuato andando sulla voce altro e da li ho fatto le dovute partizioni. Ora il problema è che all'avvio non mi carica il Grub per scegliere il sistema operativo tranne se premo esc e lo faccio partire manualmente. Ho fatto tutte le operazioni riportate sulla pagina dei manuali "https://wiki.ubuntu-it.org/AmministrazioneSistema/Grub/Errori". Ma niente non va. Questo mi si presenta all'efibootmgr:

efibootmgr -v

Timeout: 0 seconds

BootOrder: 0002,3001,0001,0000,2001,2002

Boot0000* Notebook Hard Drive - TOSHIBA MQ01ABF050 BBS(HD,Notebook Hard Drive - TOSHIBA MQ01ABF050,0x500)................-.N.......N.A.N.....................................k.......A.........................

Boot0001* Windows Boot Manager HD(1,GPT,bf5f63dd-5865-404f-a034-599d33da1052,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....C...............

Boot0002* ubuntu HD(1,GPT,bf5f63dd-5865-404f-a034-599d33da1052,0x800,0x82000)/File(\EFI\ubuntu\shimx64.efi)

Boot2001* EFI USB Device RC

Boot2002* EFI DVD/CDROM RC

Boot3001* Internal Hard Disk or Solid State Disk RC

Cambiando l'ordine e mettendo Ubuntu come primo 0002, al riavvio successivo parte Windows e tornando in Ubuntu l'ordine torna come se non l'avessi mai modificato.

Ubuntu mi risulta installato in modalità UEFI.

Spero che qualcuno possa aiutarmi. Grazie

chiesto 27 May, 21:22

rossi2's gravatar image

rossi2
10

modificato 27 May, 21:24

(27 May, 23:48) sacarde sacarde's gravatar image

12avanti »

Spero che qualcuno possa aiutarmi

coll. permanente

ha risposto 27 May, 21:29

rossi2's gravatar image

rossi2
10

Niente ho seguito i passi non funziona lo stesso

coll. permanente

ha risposto 28 May, 21:57

rossi2's gravatar image

rossi2
10

  • quanti dischi hai?

  • grub lo vedi partire? o si ferma prima?

(29 May, 08:09) sacarde sacarde's gravatar image

Ho un solo disco, il grub propio non lo visualizzo tranne se al riavvio da windows lo faccio partire manualmente. Ho addirittura provato a formattare tutto il pc con il recovery manager di HP ma quando ho provato a reinstallare Ubuntu addirittura mi diceva "Non è stato trovato alcun sistema operativo installato su questo computer. Come procedere?".

coll. permanente

ha risposto 30 May, 22:47

rossi2's gravatar image

rossi2
10

  • e' la prima volta che gira un linux su questo PC?

  • hai dischi sata particolari?

(30 May, 23:35) sacarde sacarde's gravatar image

dopo che hai formattato tutto, ti sei trovato le partizioni:

/boot

/

/home (se l'hai fatta)

?

(31 May, 09:45) sacarde sacarde's gravatar image

No non è la prima volta che linux gira su questo pc. L'ho disinstallato per poi provare a installare la versione nuova LTS ma neanche tornato alla verisione vecchia (20.04 LTS) durante l'installazione mi riconosce Windows. Attualmente dopo aver formattato tutto ho solo windows.

Il disco è Toshiba MQ01ABF050.

Questo è ciò che al momento mi si presenta:

Volume 0 E DVD-ROM 0 b Nessun su

Volume 1 C WINDOWS NTFS Partizione 448 Gb Integro Avvio

Volume 2 D RECOVERY NTFS Partizione 15 Gb Integro

Volume 3 FAT32 Partizione 260 Mb Integro Sistema

Volume 4 Windows RE NTFS Partizione 980 Mb Integro Nascosto

coll. permanente

ha risposto 31 May, 15:55

rossi2's gravatar image

rossi2
10

  • dalla live ubuntu il disco lo riconosce? trova le partizioni? (i vari "volumi" sono le partizioni, no?)

  • sembrerebbe un problema tipo di impostazione fastboot da windows

(31 May, 17:28) sacarde sacarde's gravatar image

Si trova le partizioni, ma non riconosce Windows infatti ci sono le opzioni "cancella disco" e "altro", ma non l'opzione installa accanto a Windows.

coll. permanente

ha risposto 01 Jun, 21:48

rossi2's gravatar image

rossi2
10

(02 Jun, 10:04) sacarde sacarde's gravatar image

Ciao, ho formattato completamente il notebook, ora l'installer di Ubuntu mi riconosce Windows ma vorrei sapere come devo settare il BIOS al meglio per Ubuntu? In altre parole la modalità Legacy support la devo disabilitare o no? Nelle guide spiegano molte cose ma alla fine non capisco cosa è meglio fare. Il secure boot l'ho disattivato mentre l'AHCI non la trovo da settare nel BIOS dell'HP. Grazie 🙂

coll. permanente

ha risposto 04 Jun, 22:25

rossi2's gravatar image

rossi2
10

Facendo da live sudo parted -l mi dà GPT

coll. permanente

ha risposto 04 Jun, 22:26

rossi2's gravatar image

rossi2
10

  • la modalita' "legacy" serve quando ci sono problemi a installare con uefi, non mi sembra il tuo caso...

quindi tieniti la uefi con la partizione /boot in fat

  • quindi funzionerebbe tutto adesso?
(05 Jun, 08:31) sacarde sacarde's gravatar image

Devo installarlo ma riconoscendo Windows all'installer non ci dovrebbero essere problemi (penso) Volevo però sapere se installarlo con la modalità Legacy attiva o disattivata. Il secure boot lo devo disattivare invece.

coll. permanente

ha risposto 05 Jun, 13:04

rossi2's gravatar image

rossi2
10

  • dovrebbe andare bene con la "uefi"

  • per sicurezza io lo disattiverei

https://wiki.ubuntu-it.org/AmministrazioneSistema/Uefi#Disattivazione_Secure_Boot

(05 Jun, 14:27) sacarde sacarde's gravatar image

Ok adesso vedo allora. Grazie per il tuo supporto

coll. permanente

ha risposto 05 Jun, 16:18

rossi2's gravatar image

rossi2
10

Niente, ho installato ubuntu 20.04 dopo aver formattato windows e nonostante nell'installer mi riconosce windows dopo l'installazione il menù del grub non me lo visualizza, non so più che fare.

coll. permanente

ha risposto 05 Jun, 21:12

rossi2's gravatar image

rossi2
10

dal ripristino grub, eseguendo il comando:

update-grub

adesso vede anche il sistema windows|?

(06 Jun, 14:44) sacarde sacarde's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×2,035
×319
×248

domanda posta: 27 May, 21:22

domanda visualizzata: 151 volte

ultimo aggiornamento: 23 Jun, 17:02

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.