Buongiorno a tutti, volevo aggiornare Opera browser su Ubuntu 18.04.6, ho fatto prima apt full-upgrade ma non mi da nessun pacchetto da aggiornare, mentre se do apt update mi dice: 1 pacchetto può essere aggiornato: eseguire "apt list --upgradable" per vederlo. Faccio cio' che mi dice ed effettivamente vedo che esiste una versione piu' aggiornata. Me la scarico dal sito in formato .deb e quando la installo mi dice: Reading package lists... Done Building dependency tree
Reading state information... Done Reading state information... Done Questo pacchetto non è installabile Dependency is not satisfiable: libgcc-s1 (>= 3.0)

Chi puo' aiutarmi ? Su internet non ho trovato nulla... Non siamo ancora alla scadenza della distribuzione Ubuntu 18.04.6, perche' non posso installare la versione piu' aggiornata di opera browser? Grazie

chiesto 25 Jun, 16:03

agostinom74's gravatar image

agostinom74
10101516

se la trovi nei repo perche' la scarichi? non basta:

sudo apt install opera... ecc oppure da snap

qui vari esempi:

https://wiki.ubuntu-it.org/InternetRete/Navigazione/Opera

(25 Jun, 17:01) sacarde sacarde's gravatar image

fatto come dici tu , ecco la risposta:

sudo apt install opera-stable Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto Alcuni pacchetti non possono essere installati. Questo può voler dire che è stata richiesta una situazione impossibile oppure, se si sta usando una distribuzione in sviluppo, che alcuni pacchetti richiesti non sono ancora stati creati o sono stati rimossi da Incoming.

(25 Jun, 17:53) agostinom74 agostinom74's gravatar image

e poi a seguire : Le seguenti informazioni possono aiutare a risolvere la situazione: I seguenti pacchetti hanno dipendenze non soddisfatte: opera-stable : Dipende: libgcc-s1 (>= 3.0) ma non è installabile E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

(25 Jun, 17:53) agostinom74 agostinom74's gravatar image

ecco perche' avevo provato a scaricarla in formato debian dal sito di opera , ma tanto mi dice lo stesso libgcc-s1 non installabile

(25 Jun, 17:55) agostinom74 agostinom74's gravatar image
  • hai aggiornato gli indici? con: sudo apt update

e per installare le dipendenze non soddisfatte con: sudo apt -f install

  • o installi con "snap" (se c'e' la versione che vuoi,vedi link)
(25 Jun, 18:19) sacarde sacarde's gravatar image

da root: apt update Trovato:1 http://it.archive.ubuntu.com/ubuntu bionic InRelease Trovato:2 http://it.archive.ubuntu.com/ubuntu bionic-updates InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu bionic-backports InRelease
Trovato:4 http://security.ubuntu.com/ubuntu bionic-security InRelease
Trovato:5 https://deb.opera.com/opera-stable stable InRelease
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze

1 pacchetto può essere aggiornato: eseguire "apt list --upgradable" per vederlo.

(25 Jun, 18:33) agostinom74 agostinom74's gravatar image

dato comando apt list mi dice che disponibile nuova versione di Opera... poi dato : apt -f install Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto 0 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.

(25 Jun, 18:35) agostinom74 agostinom74's gravatar image

e poi si ricomincia daccapo , dai apt install e ti dice quello che ti ho gia' scritto.. ti faccio notare che fino ad oggi ho aggiornato alle versioni successive sempre e solo con : apt update e apt full-upgrade ... questa novita' con quel messaggio e' venuta fuori da ieri

(25 Jun, 18:36) agostinom74 agostinom74's gravatar image

snap preferisco non provare, i pacchetti snap mi occupano il 70% di ram , li ho rimossi tutti e installati con apt... comunque il messaggio delle dipendenze dice che ci sono pacchetto obsoleti o danneggiati / bloccati ... io non ci capisco niente cosa vuole , non so proprio che fare ... ho provato come dicevo pure a scaricare il pacchetto debian completo dal sito ... come aggiorno libgcc... non so manco cos'e'

(25 Jun, 18:38) agostinom74 agostinom74's gravatar image

mi dici come si chiamano esattamente i pacchetti opera e libgcc?

sudo dpkg -l | grep opera

sudo dpkg -l | grep libgcc

(25 Jun, 20:40) sacarde sacarde's gravatar image

PRIMO COMANDO ESCE: 2.1.5+deb1+cvs20081104-13.2 amd64 ejects CDs and operates CD-Changers under Linux ii gpg 2.2.4-1ubuntu1.5 amd64 GNU Privacy Guard -- minimalist public key operations ii opera-stable 87.0.4390.45 amd64 Fast, secure, easy-to-use web browser ii python3-macaroonbakery 1.1.3-1 all Higher-level macaroon operations for Python 3

(26 Jun, 08:41) agostinom74 agostinom74's gravatar image

IL SECONDO COMANDO ESCE: ii libgcc1:amd64 1:8.4.0-1ubuntu1~18.04 amd64 GCC support library

(26 Jun, 08:42) agostinom74 agostinom74's gravatar image

L'ultima versione di Opera uscita e': opera-stable_88.0.4412.53_amd64

(26 Jun, 08:44) agostinom74 agostinom74's gravatar image

sai un'altra cosa strana? se vado nelle proprieta' di Opera e faccio aggiorna dal pulsante (nel menu delle proprieta' del browser) mi dice che sto utilizzando l'ultima versione disponibile invece l'ultima e' la 88.0.4412.53. E' come quando faccio apt full-upgrade mi dice che non ci sono pacchetti da aggiornare. Tuttavia se do apt install opera-stable mi dice che e' presente una nuova versione MA CHE NON si puo' installare perche' ci sono pacchetti danneggiati/bloccati e dipendenze non soddisfatte , come da messaggio che ti ho mandato sopra

(26 Jun, 09:05) agostinom74 agostinom74's gravatar image
  • ti ricordi come hai installato opera-stable 87.0.4390.45 ?

  • per libgcc1 in effetti l'ultima versione installabile sull 18.04 pare la 1:8.4.0-1ubuntu1~18.04

(26 Jun, 09:09) sacarde sacarde's gravatar image

quando avvii opera, quale binario stai eseguendo?

ps aux|grep opera

(26 Jun, 09:15) sacarde sacarde's gravatar image

ps aux|grep opera-stable agostino 7539 0.0 0.0 14436 1016 pts/0 S+ 09:28 0:00 grep --color=auto opera-stable

(26 Jun, 09:28) agostinom74 agostinom74's gravatar image

Io credo che all'epoca abbia installato opera con apt install... difatti se vado ad Ubuntu Software c'e' opera versione ultima la 88.0xxxxx ma con pacchetto snap . Ti ho detto pero' che i pacchetti snap mi mandano in overweight la ram , avevo provato skype e qualche altro ma il computer non si muoveva piu e dando ps -aux i processi degli snap erano al 99% per cui ho rimosso tutti i pacchetti snap e installati con apt

(26 Jun, 09:32) agostinom74 agostinom74's gravatar image

comunque io l'ho sempre aggiornata da anni con apt full-upgrade solo recentemente mi ha dato quel problema. Ad ogni modo se Ubuntu 18.04 LTS non ha ancora il supporto scaduto e si rilasciano ancora aggiornamenti perche' non dovrebbe essere possibile aggiornare Opera ? mah

(26 Jun, 09:35) agostinom74 agostinom74's gravatar image
  • anche a me non piacciono gli snap

  • eseguendo: "opera-stable -v" o "opera-stable -version" dovresti avere la versione, non ti trova aggiornamenti tra i repo ufficiali, ma potresti provare a aggiungere il repo come dice il link di sopra

https://wiki.ubuntu-it.org/InternetRete/Navigazione/Opera#Tramite_aggiunta_repository

(26 Jun, 09:48) sacarde sacarde's gravatar image

la versione attuale gia' la conosco ed e' la : 87.0.4390.45... come gia' avevo scritto. La procedura che mi hai inviato non sono in grado di effettuarla, io sono capace ad installare i pacchetti con apt oppure in formato debian, nulla piu'... tra l'atro ho paura pure di fare qualche casino con quella procedura, ci sono molti comandi da dare... possibile non si riesca a capire perche' quella dipendenza non e' soddisfatta e perche' mi da errore ? meglio del pacchetto debian dal sito non credo ci sia

(26 Jun, 20:14) agostinom74 agostinom74's gravatar image

e poi finora ha sempre funzionato aggiornando con apt , deve essere successo qualcosa nel rilascio della nuova versione forse l'hanno creata solo per le distribuzioni piu recenti tipo Ubuntu 20 e 22 LTS ... possibile? visto che quel file libgcc-s1 (>= 3.0) non gli piace

(26 Jun, 20:18) agostinom74 agostinom74's gravatar image

non vorrei proprio ripiegare agli snap.. il computer e' morto con gli snap ... quel maledetto processo snapd che succhia il 99% della ram ... secondo te se cerco il supporto di Opera potrebbero darmi una mano? remoto secondo me

(26 Jun, 20:21) agostinom74 agostinom74's gravatar image

non ho ancora trovato libgcc-s1 per la 18.04

domani faccio delle prove su una vm

p.s. intendi qui? https://forums.opera.com/

oppure nei canali irc

(26 Jun, 21:00) sacarde sacarde's gravatar image

si intendevo ai forum , ma non penso possano darmi una mano... dovrebbero essere esperti di distribuzioni Ubuntu e non penso affatto lo siano ... d'altronde l'errore non e' di Opera ma di un pacchetto dipendenze di Ubuntu ... quelli di Opera che ne sanno ... ma perche' ora ci vuole libgcc-s1 e fino ad ora no? allora sei d'accordo che hanno messo qualcosa in piu nella versione nuova di Opera . Grazie per i tuoi tentativi

(26 Jun, 23:11) agostinom74 agostinom74's gravatar image

posterò la domanda su quel forum , tu hai verificato qualcosa con la virtual machine? comunque come hai visto, su quel forum ci sono solo 3 interventi circa la problematiche linux con Opera , pochissimi ... dubito che risponda qualcuno

(27 Jun, 14:51) agostinom74 agostinom74's gravatar image

purtroppo anche a me (inserendo il repo per opera) successivamente non trova il libgcc-s1 (pacchetto che esiste ma per la 20.04)

continuo a indagare

(27 Jun, 17:13) sacarde sacarde's gravatar image

a me sulla macchina virtuale scaricando e installando i pacchetti della 20.04

libgcc-s1

gcc-10-base

opera-88 viene installata e funziona....

pero' e' un'operazione un po scorretta... credo

  • quindi ti serve veramente la versione 88? sei su un sistema di produzione o comunque che "deve" funzionare ?

  • oppure passa alla 20.04

(27 Jun, 18:00) sacarde sacarde's gravatar image

allora sono degli imbecilli gli sviluppatori di Opera... fanno una versione che non è supportata da sistemi operativi ancora in funzione? Sai qual'è la questione? il discorso non è che io debba per forza installare l'ultima versione, ma ne usciranno altre e fra un paio di mesi con la versione obsoleta avrò problemi a visualizzare alcuni siti internet... questa mania di rilasciare nuove versioni una o due volte a settimana farà diventare obsoleta la versione che posseggo, ovvero l'ultima rilasciata per Ubuntu 18 che è supportato ancora fino ad aprile 2023

(27 Jun, 18:40) agostinom74 agostinom74's gravatar image

se la questione è installare solo qualche pacchetto di Ubuntu 20 perchè dici che è scorretto? vuoi dire che renderebbe forse instabile il tutto sistema? se non è cosi e mi dici cosa devo installare lo faccio. Però forse non sai se dopo ci sono problemi... io non so di certo, comunque che palle guarda , pensavo cha almeno fino al 2023 non avessi problemi

(27 Jun, 18:42) agostinom74 agostinom74's gravatar image

non so bene a cosa si andrebbe in contro installando pacchetti di un'altra versione

secondo me finche puoi rimani con un sistema "pulito"

p.s. magari chiedere sul forum italiano o internazionale

(27 Jun, 20:36) sacarde sacarde's gravatar image
(29 Jun, 16:50) sacarde sacarde's gravatar image

Io sicuramente ne so meno di te ... comunque ho inteso che devo usare un altro browser fintanto che posso aggiornarlo. Firefox ancora si aggiorna, usero' quello ... questo ultimo link e' una pagina immensa , cosa devo guardare ?

(29 Jun, 17:00) agostinom74 agostinom74's gravatar image

pero' scusa se con la virtual machine hai provato installando libgcc-s1 e funziona che sara' mai installare un pacchetto in piu' ? Non credo si comprometta il sistema, a cosa serve libgcc-1? Se lo utilizza solo Opera non penso sia dannoso. Se invece lo utilizzano altri programmi e installandolo si sostituiscono le versioni precedenti forse puo' dar fastidio... In altre parole se e' un pacchetto nuovo aggiuntivo di cui ha bisogno la nuova versione di OPera credo si possa installare tranquillamente, se invece sovrascrive e si sostituisce altra roba allora no, che ne pensi?

(29 Jun, 18:08) agostinom74 agostinom74's gravatar image

io non sono esperto non saprei ... comunque tu avevi provato a installare solo quello e subito Opera funzionava? come si installa? dimmi la procedura e i comandi esatti...

(29 Jun, 18:10) agostinom74 agostinom74's gravatar image

li installi nell'ordine:

sudo dpkg -i libgcc-s1.........deb

sudo dpkg -i gcc-10-base.......deb

sudo dpkg -i opera.............deb

(29 Jun, 21:03) sacarde sacarde's gravatar image

eccomi qua, mi sono dovuto assentare qualche gg.... proverò quello che scrivete e vi farò sapere , speriamo che funzioni, grazie intanto

(07 Jul, 10:35) agostinom74 agostinom74's gravatar image

comunque questo tuo suggerimento potrebbe funzionare perchè sono i pacchetti che Ubuntu lamenta di non avere ... speriamo che non si imputtani il sistema .... ti aggiorno, grazie

(07 Jul, 10:56) agostinom74 agostinom74's gravatar image

In una parola : GRAZIE!!! Sono riuscito a installare l'ultima versione di Opera, finalmente!!!!! Solo che l'ordine di installazione non e' quello che mi hai scritto, voleva prima il secondo pacchetto e poi dopo mi ha fatto installare il primo e infine opera. Tutto liscio, non so come ringraziarti... Grazie Sacarde sei sempre un grande nella risoluzione delle problematiche Linux!!!

(07 Jul, 18:47) agostinom74 agostinom74's gravatar image

ora pero' potro' continuare ad installare le versioni successive con apt full-upgrade come andava prima della nascita del problema? Oppure devo sempre prendere l'ultimo pacchetto .deb dal sito ?

(07 Jul, 19:04) agostinom74 agostinom74's gravatar image

con "apt ..." cerchi nei repo ... che in genere non hanno le versioni recenti

dovrai scaricare il .deb sperando che le dipendenze non si modifichino

(07 Jul, 20:44) sacarde sacarde's gravatar image

stasera con apt full-upgrade mi ha trovato una versione ancora successiva e l'ha installata !!! Speriamo che duri altrimenti mi scarico il .deb dal sito ogni tanto... Grazie

(08 Jul, 23:58) agostinom74 agostinom74's gravatar image

Ho appena risolto un problema analogo, ho seguito queste istruzioni: https://www.wikihow.it/Installare-il-Browser-Opera-su-Ubuntu-Tramite-Finestra-Terminale#:~:text=All%27interno%20della%20finestra%20Terminale%2C%20digita%20o%20copia%2Fincolla,get%20update%2C%20dopodiché%20premi%20Invio.&text=Per%20installare%20Opera%2C%20digita%20o,dopodiché%20premi%20il%20tasto%20Invio.

Ho solo variato l'ultima istruzione: da "sudo apt-get install opera" a" sudo apt-get install opera-stable"

(occhio che nelle istruzioni si da per scontato che tu abbia gedit installato, semmai sostituisci "gedit" con quello che hai effettivamente)

coll. permanente

ha risposto 05 Jul, 09:28

gunnar's gravatar image

gunnar
30159

proverò anche a seguire questa procedura , anche se non comprendo molto il perchè aggiungere la chiave e il repository di opera con gedit se già c'e e la versione precedente funziona, visto poi che il terminale mi da chiare indicazioni che gli manca o è danneggiato/obsoleto il pacchetto libgcc-s1... ma non essendo un esperto, anzi tutt'altro, proverò senz'altro a vedere che succede. Grazie intanto per il tuo aiuto, ti farò sapere

(07 Jul, 10:53) agostinom74 agostinom74's gravatar image

Grazie, come ho scritto sopra ho risolto !!!

(07 Jul, 19:02) agostinom74 agostinom74's gravatar image

Comunque le tue critiche ad Opera sono molto condivisibili!

(13 Jul, 10:21) gunnar gunnar's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×42

domanda posta: 25 Jun, 16:03

domanda visualizzata: 203 volte

ultimo aggiornamento: 13 Jul, 10:21

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.