Ciao a tutti, premetto che ho installato Ubuntu 13.10 15 giorni fa! Potete capire il mio problema!

Allora, vorrei installare un programma gestionale di nome MiGe. Mi dice che la dipendenza non può essere soddisfatta: libwxgtk2.6-0.

Ho usato anche il Gestore Pacchetti, ma dopo un paio di minuti di download mi dice che è impossibile scaricare il file e va in errore.

Avete qualche consiglio?

chiesto 09 Nov '13, 02:58

Alessio's gravatar image

Alessio
20112

modificato 09 Nov '13, 07:43

enzotib's gravatar image

enzotib ♦♦
14.0k112186

Dove hai preso questo programma, dato che non è nei repo? Cosa hai fatto con Gestore Pacchetti? Che errore ti dà? Sono tutte informazioni essenziali per capire il problema.

(09 Nov '13, 07:48) enzotib ♦♦ enzotib's gravatar image

Il problema sta nel fatto che il software richiede una dipendenza, ovvero libwxgtk2.6-0, che è si presente nei repository ma a una versione più recente, ovvero libwxgtk2.8-0, non compatibile con quel programma. A me da anche lo stesso errore ma con Python, infatti il programma richiede la versione di Python 2.6 mentre sui repository sono presenti solo le versioni dalla Python 2.7 in poi. Una possibile soluzione, che non ho però testato e perciò dagli effetti ignoti, sarebbe scaricare ed installare il pacchetto mancante da qui.

coll. permanente

ha risposto 09 Nov '13, 14:17

jorged's gravatar image

jorged
3.0k101653

modificato 09 Nov '13, 14:17

1

solitamente quando tenti di installare una versione meno recente di un file, programma o libreria come in questo caso viene mostrato un avviso in cui si avverte che è presente una versione più recente nei repo o che è già installata una versione più recente, ed eventuali conflitti in caso si prosegua con l'installazione. Se invece le due librerie possono coesistere nello stesso sistema questo messaggio non dovrebbe apparire.

(09 Nov '13, 16:02) m3nhir m3nhir's gravatar image
La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×32

domanda posta: 09 Nov '13, 02:58

domanda visualizzata: 1,234 volte

ultimo aggiornamento: 09 Nov '13, 16:02

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.