ehi ciao ho deciso di mettere lubuntu sul vecchio pc fisso di mamma perche l'attesa a ogmni minima mossa era n'agonia, pero non riesco a far si che sia tutto in italiano(e visto che lo usa mamma e fondamentale) tipo skanlite o image viewer sono in inglese. ho gia provato diverse cose, non ho supporto lingua ma lingua e paese che non mi consente di spuntare "applica globalmente" come ho trovato in varie ricerche, e comunque li è impostata la lingua italiana. poi mi sono assicurata da terminale che questi pacchetti fossero installati ->

language-pack-it
language-pack-it-base
language-pack-gnome-it
language-pack-gnome-it-base
menu-l10n

e anche questi ->

language-pack-it
language-pack-it-base
language-pack-kde-it
hyphen-it
hunspell-it
ispell
iitalian
menu-l10n

qttranslations-l10n questo pero non me lo trova per poterlo installare
ho lanciato il comando ->

sudo dpkg-reconfigure --force locales

e mi dice così->

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "it_IT.UTF-8",
        LC_NAME = "it_IT.UTF-8",
        LC_MONETARY = "it_IT.UTF-8",
        LC_PAPER = "it_IT.UTF-8",
        LC_IDENTIFICATION = "it_IT.UTF-8",
        LC_TELEPHONE = "it_IT.UTF-8",
        LC_MEASUREMENT = "it_IT.UTF-8",
        LC_TIME = "it_IT.UTF-8",
        LC_COLLATE = "scn_IT.UTF-8",
        LC_NUMERIC = "it_IT.UTF-8",
        LANG = "it_IT.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("it_IT.UTF-8").
locale: Impossibile impostare LC_ALL come locale predefinito: File o directory non esistente
/usr/bin/locale: Impossibile impostare LC_ALL come locale predefinito: File o directory non esistente

quando mi apre la configurazione in corso di locales ci sono tre asterischi nella lista due sull'italiano e uno inglese ->

[*] en_US.UTF-8 UTF-8 
[*] it_IT ISO-8859-1
[*] it_IT.UTF-8 UTF-8

e non so come togliere gli asperischi dall'inglese e dall'italiano "errato" e dopo che do invio su [*] it_IT.UTF-8 UTF-8 e ok mi dice cosi

Generating locales (this might take a while)...
  en_AG.UTF-8... done
  en_AU.UTF-8... done
  en_BW.UTF-8... done
  en_CA.UTF-8... done
  en_DK.UTF-8... done
  en_GB.UTF-8... done
  en_HK.UTF-8... done
  en_IE.UTF-8... done
  en_IL.UTF-8... done
  en_IN.UTF-8... done
  en_NG.UTF-8... done
  en_NZ.UTF-8... done
  en_PH.UTF-8... done
  en_SG.UTF-8... done
  en_US.UTF-8... done
  en_ZA.UTF-8... done
  en_ZM.UTF-8... done
  en_ZW.UTF-8... done
  it_CH.UTF-8... done
  it_IT.ISO-8859-1... done
  it_IT.UTF-8... done
Generation complete.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_TIME = "it_IT.UTF-8",
        LC_MONETARY = "it_IT.UTF-8",
        LC_COLLATE = "scn_IT.UTF-8",
        LC_ADDRESS = "it_IT.UTF-8",
        LC_TELEPHONE = "it_IT.UTF-8",
        LC_NAME = "it_IT.UTF-8",
        LC_MEASUREMENT = "it_IT.UTF-8",
        LC_IDENTIFICATION = "it_IT.UTF-8",
        LC_NUMERIC = "it_IT.UTF-8",
        LC_PAPER = "it_IT.UTF-8",
        LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_TIME = "it_IT.UTF-8",
        LC_MONETARY = "it_IT.UTF-8",
        LC_COLLATE = "scn_IT.UTF-8",
        LC_ADDRESS = "it_IT.UTF-8",
        LC_TELEPHONE = "it_IT.UTF-8",
        LC_NAME = "it_IT.UTF-8",
        LC_MEASUREMENT = "it_IT.UTF-8",
        LC_IDENTIFICATION = "it_IT.UTF-8",
        LC_NUMERIC = "it_IT.UTF-8",
        LC_PAPER = "it_IT.UTF-8",
        LANG = "C"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

se provo a lanciare /etc/default/locale mi dice così ->

bash: /etc/default/locale: Permesso negato

ps prima di lanciarlo cosi a caso l'ho eseguito con gedit (che ho dovuto installare) ho aperto il "file" e ho visto che li su language e in tutte le voci menzionate era presente it-IT.utf-8 cosi ho disinstallato gedit perche pensavo fosse inutile tenerlo visto che avevo appurato che era tutto apposto in quel file e poi ho provato a lanciare il comando->

export LC_ALL=it_IT.UTF-8

ma mi risponde così ->

bash: attenzione: setlocale: LC_ALL: impossibile cambiare la localizzazione (it-IT): File o directory non esistente

poi ho provato a installare il pacchetto language-support.it ma non me lo trova

Forse ho dimenticato altri tentativi che ho fatto, non so piu che ricerche fare e cosa provare.
PS sono una novellina ho installato linux mint sul mio portatile e se ho qualche problema faccio delle ricerche e generalmente me la sono sempre cavata andando un po a tentoni, qua sul fisso di mamma gli ho messo lubuntu ho gia sistemato qualche cosina ma sta roba dell'inglese non ne vengo a capo, questo per dire siate clementi non arrabbiatevi per le terminologie che ho usato (ho cercato di spiegare tutto al meglio delle mie conoscenze del momento) e cercate di parlare il piu potabile possibile vi prego

chiesto 15 Jan, 17:11

sil15's gravatar image

sil15
101

modificato 17 Jan, 10:28

enzotib's gravatar image

enzotib ♦♦
14.1k113187

probabilmente alcuni pacchetti non hanno una traduzione completa,altri devi aprire il menu preferenze e scegliere la lingua.sudo locale purge nel terminale aiuta a togliere le lingue in piu .dal menu installa lingue anche puoi togliere lingue con installa lingue e togliendo le altre lingue.. provare lo spurgo totale e stato tradutto in automatico Sudo Locale Purge

(17 Jan, 08:48) mimmopasca mimmopasca's gravatar image

Le risposte servono per proporre soluzioni, non usarle per altro, usa i commenti

(17 Jan, 21:24) enzotib ♦♦ enzotib's gravatar image

ho provato infatti a guardarmi in giro nelle impostazioni dei singoli programmi ma per esempio il gestore pacchetti muon è scritto in italiano sullo start ma poi quando lo apri sulla finestra in alto è rinominato in inglese ( muon package manager) ed è tutto in inglese dalle descrizioni dei pacchetti alle "caselline sopra" (vi prego perdonatemi) file settings ecc... nonostante anche li sono entrata nei setting e ho impostato tutto in italiano ravviato ecc non succede nulla ho provato a lanciare sudo locale purge ma mi da questo

(17 Jan, 22:37) sil15 sil15's gravatar image

locale: Impossibile impostare LC_ALL come locale predefinito: File o directory non esistente locale: nome sconosciuto "purge"

infatti uno dei problemi riportati sopra e che la lingua locale me la da "unset"->

LC_ALL = (unset) e LANGUAGE = ""

e non riesco a capire come impostare bene sta roba perché appunto ho provato tutte le possibili soluzioni che ho trovato in rete e ho cercato di verificare tutto cio che mi sembrava sensato

(17 Jan, 22:37) sil15 sil15's gravatar image
Scrivi tu la prima risposta!
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×110

domanda posta: 15 Jan, 17:11

domanda visualizzata: 135 volte

ultimo aggiornamento: 18 Jan, 08:16

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.