Salve a tutti.
Avrei bisogno di aiuto, non mi viene eseguito l'avanzamento alla versione 12.04.3 LTS perché ci sono dipendenze irrisolte.
Credo di sapere a cosa si riferisce: tempo fa avevo installato Geogebra e da lì sono nati un sacco di problemi che ho risolto, ma evidentemente non in modo definitivo.

Grazie per l'aiuto

chiesto 01 Dic '13, 07:32

toni63's gravatar image

toni63
10113

modificato 01 Dic '13, 12:51

enzotib's gravatar image

enzotib ♦♦
14.0k112186

1

Per evitarti altri problemi sarebbe meglio sapere qual'è la versione in uso che vuoi aggiornare.

(01 Dic '13, 10:16) enzoge enzoge's gravatar image

la versione attuale è 10.04.4 LTS

(01 Dic '13, 10:22) toni63 toni63's gravatar image
1

@toni63: Le risposte non servono per chiedere chiarimenti o comunicare i risultati di qualcosa, ma tutto questo può essere scritto tramite i commenti.

(01 Dic '13, 10:51) enzotib ♦♦ enzotib's gravatar image

coll. permanente

ha risposto 01 Dic '13, 10:31

enzoge's gravatar image

enzoge
4.6k203987

Come scritto nel link, ho eseguito i comandi

sudo apt-get clean sudo apt-get update && sudo apt-get upgrade

non mi ha dato problemi (dice solo che non si può eseguire l'upgrade di google-chrome), quindi ho riprovato a chiedere l'avanzamento alla nuova versione, ma ottengo questa risposta

Si è verificato un problema durante il calcolo dell'avanzamento: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

E l'avanzamento non prosegue.

P.S. Scusate se non utilizzo correttamente il servizio, ma è la prima volta che ne faccio uso.

(01 Dic '13, 11:01) toni63 toni63's gravatar image

Se guardi anche gli ultimi post trovi anche il comando: sudo apt-get -f install che è l'ultimo comando che ha risolto il problema. Per cui, siccome hai tentato l'aggiornamento prima dell'ultimo comando, ti consiglio di ripetere tutto dall'inizio. P.S. Il backup è meglio pentirsi di averlo fatto, che di non averlo fatto.

(01 Dic '13, 11:16) enzoge enzoge's gravatar image

Forse ti converrà disinstallare Geogebra e Chrome per reinstallarli ad aggiornamenti fatti

(01 Dic '13, 12:00) enzoge enzoge's gravatar image

Ho disinstallato Chrome e Geogebra. Ora sto eseguendo un backup. Avevo visto il comando "sudo apt-get -f install", ma, a differenza di quanto scritto nel post che mi hai suggerito di leggere, a me non era stato consigliato di utilizzare anche quel comando. Finito il backup lo proverò e poi ti farò sapere.

Non sono esperto neppure di punti e voti, spero di aver fatto bene.

(01 Dic '13, 22:28) toni63 toni63's gravatar image

Ho eseguito anche i comandi "sudo apt-get -f install" e "sudo apt-get autoremove" richiesto dal precedente per rimuovere "python-pexpect", ma non è cambiato nulla, l'avanzamento non funziona. Mi dice "Impossibile calcolare l'avanzamento

Si è verificato un problema durante il calcolo dell'avanzamento: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages." Ora provo anche a scaricarmi il CD, vediamo...

(01 Dic '13, 23:44) toni63 toni63's gravatar image

Da Ubuntu 12.04 LTS in poi è possibile aggiornare da CD, procedura che considero molto più sicura dell'aggiornamento via internet. Il mio consiglio è in primo luogo quello di fare un bel Back Up di tutti i tuoi dati, visto che quando si tratta di aggiornamenti è sempre meglio andarci con i piedi di piombo, ed in secondo luogo effettuare l'aggiornamento via CD, quindi masterizzando una copia di Ubuntu 12.04 LTS avviando la procedura d'istallazione e al momento della scelta del tipo d'installazione scegliere Aggiornare Ubuntu ad Ubuntu 12.04 LTS.

coll. permanente

ha risposto 01 Dic '13, 14:51

jorged's gravatar image

jorged
3.0k101653

@jorged: a quanto mi risulta anche in questo caso avviene il download da internet del software, in quanto il cd/dvd non contiene tutto

(01 Dic '13, 15:10) enzoge enzoge's gravatar image

@ilgallinetta in problema non è lo scaricamento da internet, ma la risoluzione delle dipendenze, e da questo punto di vista il CD può fare sicuramente molto di più del software per l'aggiornamento.

(01 Dic '13, 15:54) jorged jorged's gravatar image

@jorged: beh tentar non nuoce, anche se giustamente l'opzione Installa salvando i dati esistenti equivale all'avanzamento di versione.

(01 Dic '13, 16:39) enzoge enzoge's gravatar image

@ilgallinetta si ma con il vantaggio della totale reinstallazione del sistema che porta anche ad una risoluzione delle dipendenze irrisolte.

(02 Dic '13, 01:01) jorged jorged's gravatar image

@toni63:hai fatto le copie e quindi puoi fare tutte le prove che vuoi. Per prima cosa durante l'installazione puoi seguire il consiglio di jorged di selezionare "Aggiornare Ubuntu ad Ubuntu 12.04 LTS". Per essere certi che funzioni in ogni caso bisognerebbe aver esaminato il sorgente del programma di installazione, ma hai il backup e se funziona risparmi di ricaricare le copie, altrimenti dovrai installare ex novo la 12.04.3 e caricare la copia dei tuoi dati.

coll. permanente

ha risposto 02 Dic '13, 07:30

enzoge's gravatar image

enzoge
4.6k203987

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×185
×60
×32
×2

domanda posta: 01 Dic '13, 07:32

domanda visualizzata: 1,561 volte

ultimo aggiornamento: 02 Dic '13, 07:31

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.