Buonasera,
dopo aver installato ubuntu 10.10 e averlo aggiornato con i vecchi repository per fare funzionare la mia stampante samsung scx3400 il sistema mi chiede di installare un pacchetto dal nome rastertospl, che non c'è nel gestore pacchetti.
Ho inserito il file PPD come mi ha richiesto, l'ho scaricato dal sito samsung, ma comunque mi chiede sempre di installare rastertospl.
Come procedo?

Grazie a tutti per le risposte.

chiesto 02 Dic '13, 17:22

ubuntumarco's gravatar image

ubuntumarco
794613

modificato 03 Dic '13, 19:05

pietroalbini's gravatar image

pietroalbini ♦♦
3.1k2947


La 10.10 non è più supportata da maggio 2013 e i suoi repository sono stati disattivati.

Installa una versione supportata.

coll. permanente

ha risposto 03 Dic '13, 11:26

dadexix86's gravatar image

dadexix86 ♦♦
16.9k816161

perchè mai ! mi trovo benissimo con questa versione, manca un filtro dal nome rastertospl ci sarà da qualche parte basta trovarlo e mettere le cose a posto. Ho sempre usato questa versione con questa stampante non vedo perchè devo passare ad un altra versione più recente solo perchè manca un filtro.

(03 Dic '13, 12:59) ubuntumarco ubuntumarco's gravatar image

No, dovresti passare a una versione supportata a prescindere dalla stampante.

Restando con la versione vecchia non ricevi più gli aggiornamenti di sicurezza, creando quindi volontariamente delle vulnerabilità nel tuo sistema operativo, che possono essere sfruttate contro di te, ad esempio per rubarti password, dati personali, ecc.

(03 Dic '13, 13:25) dadexix86 ♦♦ dadexix86's gravatar image

aldilà di queste considerazioni valide e legittime, dove si trova il pacchetto rastertospl e come si installa ?

(03 Dic '13, 15:28) ubuntumarco ubuntumarco's gravatar image

Come puoi vedere nei repo EOL di Maverick e nei vari updates/backports (la versione 10.10) quel pacchetto non è presente.

Inoltre non è presente nemmeno in versioni successive, perché supportano la stampante direttamente.

Quello che puoi fare è cercare in quei repo EOL che ti ho linkate (in versioni precedenti a Maverick) se lo trovi e sperare di poterlo installare senza doverti portare dietro molte dipendenze.

(03 Dic '13, 15:39) dadexix86 ♦♦ dadexix86's gravatar image

ho trovato il pacchetto rastertospl in ULD_Linux_V1.00.06.tar.gz scaricato dal sito samsung, ora mi chiedo in che modo lo posso installare se si potesse e/o è possibile copiarlo nella cartella usr/lib/cups/filter ... (ci ho provato ma mi chiede permessi)

(03 Dic '13, 16:23) ubuntumarco ubuntumarco's gravatar image

Non c'è un README o qualcosa di simile dentro quel file?

(03 Dic '13, 17:06) dadexix86 ♦♦ dadexix86's gravatar image

no, c'è un file install.sh con questo testo

#!/bin/sh
SCRIPT_DIR=$(dirname "$0")

if sh "$SCRIPT_DIR/noarch/pre_install.sh" $@ ; then
    sh "$SCRIPT_DIR/noarch/worker.sh" $@ "printer-script"
    sh "$SCRIPT_DIR/noarch/worker.sh" $@ "scanner-script"
    sh "$SCRIPT_DIR/noarch/post_install.sh" $@
fi
(03 Dic '13, 17:58) ubuntumarco ubuntumarco's gravatar image

Ok, hai seguito le istruzioni presenti sulla guida che c'è da dove si scarica il driver?

(03 Dic '13, 18:03) dadexix86 ♦♦ dadexix86's gravatar image

no non ho fatto nulla anche perchè non ha trovato nessuna guida,

(03 Dic '13, 18:35) ubuntumarco ubuntumarco's gravatar image

Nella pagina da cui lo scarichi c'è la User Guide, con le istruzioni passo-passo :)

(03 Dic '13, 19:05) dadexix86 ♦♦ dadexix86's gravatar image

sto seguendo la guida ma sono gia fermo al primo passo il terminale mi chiede la psw e risponde che non conosce il comando sudo, dove sbaglio?

(04 Dic '13, 10:14) ubuntumarco ubuntumarco's gravatar image

Potresti sbagliare ovunque. Copia e incolla, eventualmente su pastebin così da non intasare la pagina, il contenuto del terminale.

(04 Dic '13, 10:49) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/6518983/ ho aperto terminale ho spacchettato il pacchetto uld_v1.00.06.tar-gz ho digitato i comandi come da guida....

(04 Dic '13, 11:23) ubuntumarco ubuntumarco's gravatar image

Come l'hai spacchettato e dove?

Se crei una nuova cartella spacchettandolo (il default sulle nuove versioni di Ubuntu, non so su quelle obsolete) poi ti ci devi spostare dentro con cd.

(04 Dic '13, 11:30) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/6519155/

ho estratto i file con gestore di archivi in una cartella sulla scrivania ho scaricato 7zip da USC per provare a farlo anche con questa applicazione ma non so dove me lo ha messo

(04 Dic '13, 12:12) ubuntumarco ubuntumarco's gravatar image

Perché hai dato questo comando?

cd [marco/scrivania/cartella senza nome 2 ]

È improbabile che tu abbia una cartella che si chiama così.

Posta (su pastebin) l'output di

ls
(04 Dic '13, 12:45) dadexix86 ♦♦ dadexix86's gravatar image

Posta anche

ls Scrivania
(04 Dic '13, 12:49) dadexix86 ♦♦ dadexix86's gravatar image

Ok, in quale di queste cartelle hai scompattato il contenuto del file? In uld?

(04 Dic '13, 13:03) dadexix86 ♦♦ dadexix86's gravatar image

si in uld grazie per il supporto e la pazienza

(04 Dic '13, 13:06) ubuntumarco ubuntumarco's gravatar image

Allora la cartella in cui devi spostarti è quella.

cd ~/Scrivania/uld

e poi dovresti poter continuare con la guida...

(04 Dic '13, 13:08) dadexix86 ♦♦ dadexix86's gravatar image

http://paste.ubuntu.com/6519419/ dovrei esserci riuscito.... ora faccio riavvio o non serve per 7zip che ho scaricato da USC che non trovo da nessuna parte?

(04 Dic '13, 13:24) ubuntumarco ubuntumarco's gravatar image

Ok :) Che c'entra 7zip e perché l'hai installato?

7zip si integra (nelle versioni attuali, non so su quelle obsolete) con il gestore degli archivi, fornendo il supporto ai file .7z.

(04 Dic '13, 13:26) dadexix86 ♦♦ dadexix86's gravatar image

Se hai risolto il problema posto nella tua domanda (installare quel pacchetto) per favore accetta la mia risposta (dato che è nei suoi commenti che abbiamo trovato la soluzione).

(04 Dic '13, 13:27) dadexix86 ♦♦ dadexix86's gravatar image

l'ho scaricato nel dubbio che servisse grazie sei stato molto gentile e paziente, e un continuo scoprire cose nuove in questo mondo e grazie a persone come te che fanno sembrare tutto più semplice

buon pranzo

(04 Dic '13, 13:32) ubuntumarco ubuntumarco's gravatar image

Prego e buon pranzo a te.

Mi raccomando, accetta la risposta, così manteniamo pulito il sito ;)

E ricordati che prima o poi, ma meglio prima, dovrai avanzare a una versione (d/r)ecente di Ubuntu, altrimenti sarà sempre più difficile aiutarti a risolvere i problemi ;)

(04 Dic '13, 13:34) dadexix86 ♦♦ dadexix86's gravatar image

sai cos'è.. che mi trovo spaesato senza il pannello in alto con Applicazioni Risorse Sistema-amministrazione preferenze, nelle versione successive sono disposti in altro modo e mi viene difficile trovare quello che mi serve in poco tempo. Farò dei virtual tour per conoscere meglio le versioni più (d/r)ecenti e prenderò buono il tuo consiglio

(04 Dic '13, 13:48) ubuntumarco ubuntumarco's gravatar image

Se sai cosa stai cercando, basta che inizi a digitare, come in Google ;)

Comunque se sei legato a quella impostazione potresti valutare il passaggio a Xubuntu, che ha un menu simile a quello del vecchio Gnome 2.

(04 Dic '13, 13:51) dadexix86 ♦♦ dadexix86's gravatar image

Penso ti convenga installare 12,04.3 lts che ha già i driver della samsung scx3400, oppure la 13.10 che anch'essa dovrebbe averli.

coll. permanente

ha risposto 02 Dic '13, 18:50

enzoge's gravatar image

enzoge
4.7k253987

La tua risposta
abilita/disabilita anteprima

Segui questa domanda

Via email:

Una volta eseguito l'accesso potrai iscriverti a tutti gli aggiornamenti qui

Via RSS:

Risposte

Risposte e commenti

Basi di markdown

  • *corsivo* o __corsivo__
  • **grassetto** o __grassetto__
  • collegamento:[testo](http://url.com/ "titolo")
  • immagine?![alt testo](/path/img.jpg "titolo")
  • elenco numerato: 1. Foo 2. Bar
  • per aggiungere un'interruzione di riga, aggiungi due spazi a fine riga e premi «Invio»
  • è supportato anche semplice HTML

Tag:

×187
×4

domanda posta: 02 Dic '13, 17:22

domanda visualizzata: 2,966 volte

ultimo aggiornamento: 04 Dic '13, 13:51

Chiedi è un servizio di supporto gestito da Ubuntu-it. Contattaci!

powered by OSQAPostgreSQL database
Ubuntu e Canonical sono marchi registrati da Canonical Ltd.